Release 9.2.5

Changes

  • Queue Manager Swiftlet: Instead of just a long value, the message viewer of SwiftMQ Explorer / CLI now displays the formatted local time of the router for JMSExpiration and JMSTimestamp messages properties.
  • AMQP Bridge Swiftlet: If a bridge is disabled, only the connection is closed which implicitely closes all sessions and links.

Bugfixes

  • Message Selector: LIKE predicate %CCAB does not match CCAB.
  • Topic Manager Swiftlet: Queues are not unlocked and a deadlock occurs if the queue controller for durable subscribers has a max-messages value defined like below and this number of messages is reached at one durable subscriber during a transaction that spans multiple durable subscribers.

Compatibility

  • Configuration compatible with previous releases: 4.5.0 (routerconfig.xml will be converted on the first startup)
  • Class compatible with previous releases: 5.1.0 (see release notes of release 5.1.0).
  • Message compatible with previous releases: 4.0.0
  • Store compatible with previous releases: 4.0.0
  • Protocol compatible with previous releases: 4.0.0

How to Upgrade

SwiftMQ 9.2.5 defines two AMQP listeners on port 5672 (plain) and 5671 (SSL/TLS) to be able to run AMQP out of the box. They will also be added as part of the rolling upgrade process as specified on the links below. If you don't need these listeners, you may either delete them *after* the upgrade or use the "NOAMQP" option on the new release *during* the upgrade on the first start of the router start script of the new release, e.g:

        ./smqr1 NOAMQP

or

        ./smqr1_replicated NOAMQP

The option work on HA and non-HA releases but only on the very first start where the config files will be upgraded.